Solmio-kassa - Netsin maksunvälityksessä häiriöitä – Incident details

Netsin maksunvälityksessä häiriöitä

Resolved
Major outage
Started 27 days agoLasted about 8 hours

Affected

Payment Backend

Operational from 8:02 AM to 4:00 PM

App

Operational from 8:02 AM to 4:00 PM

Acquirer Connections

Partial outage from 8:02 AM to 8:53 AM, Operational from 8:02 AM to 4:00 PM, Major outage from 8:53 AM to 1:35 PM, Operational from 1:35 PM to 4:00 PM

Nets Finland

Partial outage from 8:02 AM to 8:53 AM, Major outage from 8:53 AM to 1:35 PM, Operational from 1:35 PM to 4:00 PM

Worldline

Operational from 8:02 AM to 4:00 PM

Viva wallet

Operational from 8:02 AM to 4:00 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Nets implemented a fix. Transactions is successfull again. We will continue to monitor.

  • Identified
    Identified

    Nets:

    Update - We are continuing to work with highest priority on a fix for this issue.
    May 21, 2026 - 11:50 EEST

  • Investigating
    Investigating

    Identified - Nordic acquiring down since 10:06 EET / 9:06 CET.
    May 21, 2026 - 10:43 EEST

    Investigating - We've identified an issue with Nordic acquiring affecting our terminals in Nordics.

    I've escalated the issue.
    May 21, 2026 - 10:22 EEST